$re = '/(?<=>) \b|\b (?=<)/';
$str = '<span class="sitestr"> googleblog.com </span></a>" ) "</span><a/>" | "<a>
<span class="sitestr"> googleblog.com </span></a> ) </span><a/> | <a>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;