import Foundation
let pattern = #"(\w+)=([^\s]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"loglevel="INFO" | hostname="import-1-4-3-2053088235-873gq" | transactionId="a0991eed-46bd-49df-9545-87deae988b6c" | serviceName="import" | version="1.4.3" | thread="https-jsse-nio-8443-exec-12" | logger="c.a.e.s.l.d.s.impl.ScheduleServiceImpl " | message="Get Schedule BOC" | status="GET_SCHEDULE_BOC" | code="00139" | uri="https://layer-1-0-2.schedule-schedule/scheduleLayer/search?version=1u0026envContext=PRODu0026routeOffer=BLUE""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)