#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^NEM.[A-Z0-9]{3}.[A-Z0-9]{3,6}.[0-9]{3}.[0-9]{1,3}$"
Local $sString = "NEM.ESB.IPAB.400.001" & @CRLF & _
"NEM.ESB.IPAB.400.003" & @CRLF & _
"" & @CRLF & _
"NEM.ESB.TST.400.1" & @CRLF & _
"NEM.BPM.TST.400.1" & @CRLF & _
"NEM.ESB.TSTTST.400.1" & @CRLF & _
"NEM.BPM.TSTTST.400.1" & @CRLF & _
"" & @CRLF & _
"NEM.ESB.TST.400.001" & @CRLF & _
"NEM.BPM.TST.400.001" & @CRLF & _
"NEM.ESB.TSTTST.400.001" & @CRLF & _
"NEM.BPM.TSTTST.400.001" & @CRLF & _
"" & @CRLF & _
"NEM.ESB.AAA.000.000" & @CRLF & _
"NEM.BPM.AAA.000.000" & @CRLF & _
"NEM.ESB.AAAAAA.000.000" & @CRLF & _
"NEM.BPM.AAAAAA.000.000" & @CRLF & _
"" & @CRLF & _
"NEM.ESB.ZZZ.999.999" & @CRLF & _
"NEM.BPM.ZZZ.999.999" & @CRLF & _
"NEM.ESB.ZZZZZZ.999.999" & @CRLF & _
"NEM.BPM.ZZZZZZ.999.999" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"ANEM.ESB.TST.400.1" & @CRLF & _
"AEM.BPM.TST.400.1" & @CRLF & _
"AEM.ESB.TSTTST.400.1" & @CRLF & _
"AEM.BPM.TSTTST.400.1" & @CRLF & _
"" & @CRLF & _
"AEM.ESB.TST.400.001" & @CRLF & _
"AEM.BPM.TST.400.001" & @CRLF & _
"AEM.ESB.TSTTST.400.001" & @CRLF & _
"AEM.BPM.TSTTST.400.001" & @CRLF & _
"" & @CRLF & _
"AEM.ESB.AAA.000.000" & @CRLF & _
"AEM.BPM.AAA.000.000" & @CRLF & _
"AEM.ESB.AAAAAA.000.000" & @CRLF & _
"AEM.BPM.AAAAAA.000.000" & @CRLF & _
"" & @CRLF & _
"AEM.ESB.ZZZ.999.999" & @CRLF & _
"AEM.BPM.ZZZ.999.999" & @CRLF & _
"AEM.ESB.ZZZZZZ.999.999" & @CRLF & _
"AEM.BPM.ZZZZZZ.999.999" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")