import re
regex = re.compile(r"^NEM.[A-Z0-9]{3}.[A-Z0-9]{3,6}.[0-9]{3}.[0-9]{1,3}$", flags=re.MULTILINE)
test_str = ("NEM.ESB.IPAB.400.001\n"
"NEM.ESB.IPAB.400.003\n\n"
"NEM.ESB.TST.400.1\n"
"NEM.BPM.TST.400.1\n"
"NEM.ESB.TSTTST.400.1\n"
"NEM.BPM.TSTTST.400.1\n\n"
"NEM.ESB.TST.400.001\n"
"NEM.BPM.TST.400.001\n"
"NEM.ESB.TSTTST.400.001\n"
"NEM.BPM.TSTTST.400.001\n\n"
"NEM.ESB.AAA.000.000\n"
"NEM.BPM.AAA.000.000\n"
"NEM.ESB.AAAAAA.000.000\n"
"NEM.BPM.AAAAAA.000.000\n\n"
"NEM.ESB.ZZZ.999.999\n"
"NEM.BPM.ZZZ.999.999\n"
"NEM.ESB.ZZZZZZ.999.999\n"
"NEM.BPM.ZZZZZZ.999.999\n\n\n\n\n"
"ANEM.ESB.TST.400.1\n"
"AEM.BPM.TST.400.1\n"
"AEM.ESB.TSTTST.400.1\n"
"AEM.BPM.TSTTST.400.1\n\n"
"AEM.ESB.TST.400.001\n"
"AEM.BPM.TST.400.001\n"
"AEM.ESB.TSTTST.400.001\n"
"AEM.BPM.TSTTST.400.001\n\n"
"AEM.ESB.AAA.000.000\n"
"AEM.BPM.AAA.000.000\n"
"AEM.ESB.AAAAAA.000.000\n"
"AEM.BPM.AAAAAA.000.000\n\n"
"AEM.ESB.ZZZ.999.999\n"
"AEM.BPM.ZZZ.999.999\n"
"AEM.ESB.ZZZZZZ.999.999\n"
"AEM.BPM.ZZZZZZ.999.999\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")