using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<ref[^>]*>ABC<[^>]*>|ABC<[^>]+>";
string substitution = @"";
string input = @"Foo<ref name=""foo"">ABC</ref>ABC<ref name=""foo""/>, foo bar<ref name=""bar"">XYZ</ref>, baz, qux, quux<ref name=""bar""/><ref name=""bar"">ABC</ref>.
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}