package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<ref[^>]*>ABC<[^>]*>|ABC<[^>]+>`)
var str = `Foo<ref name="foo">ABC</ref>ABC<ref name="foo"/>, foo bar<ref name="bar">XYZ</ref>, baz, qux, quux<ref name="bar"/><ref name="bar">ABC</ref>.
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}