using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<table\b[^\>]*\bname=(\""|')?table01\1[^\>]*>(?>([^\<]+|<(?!\/?table\b))|(<table[^\>]*>(?:(?2)|(?3)|)+?<\/table>))*<\/table>";
string input = @"<table name=table01 data-measure-unit=Y>
<table></table>
</table>";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}