import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<table\\b[^\\>]*\\bname=(\\\"|')?table01\\1[^\\>]*>(?>([^\\<]+|<(?!\\/?table\\b))|(<table[^\\>]*>(?:(?2)|(?3)|)+?<\\/table>))*<\\/table>";
final String string = "<table name=table01 data-measure-unit=Y>\n"
+ " <table></table>\n"
+ "</table>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}