package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\w\W*)*:`)
var str = `15-min-sum:rate:proc.stat.cpu{host=foo,type=idle}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}