$re = '/^(\w\W*)*:/';
$str = '15-min-sum:rate:proc.stat.cpu{host=foo,type=idle}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);