import re
regex = re.compile(r"((?:\"[^\"]*)\s*\")|((?:\'[^']*)\s*\')|((?:\`[^`]*)\s*\`)|((?:\b|\s)(?:const|function|let)\s)|(?:\/\/.*$)|(?:\/\*+(?:.|\s)*\*\/)|\s*", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("function myFunction() {\n"
" let carName = \"Volvo\";\n"
" // code here CAN use carName\n"
"const test = 'string with \"quoted substring\"'; let airplane = 'fly'\n"
"(\"and another string th'' as' asd 'ere\")\n"
"labelForStrings: {\n"
" `t'is a \"string\"`\n"
" }\n"
"}\n"
"/*asd *****\n"
"* 324 @*l;;?\\\\\\\n"
"* multiline comment \n\n\n"
"*** /\n"
"*/")
subst = "$1$2$3$4"
result = regex.sub(subst, test_str)
if result:
print(result)