// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?im)((?:\"[^"]*)\s*\")|((?:\'[^']*)\s*\')|((?:\`[^`]*)\s*\`)|((?:\b|\s)(?:const|function|let)\s)|(?:\/\/.*$)|(?:\/\*+(?:.|\s)*\*\/)|\s*"#).unwrap();
let string = "function myFunction() {
let carName = \"Volvo\";
// code here CAN use carName
const test = 'string with \"quoted substring\"'; let airplane = 'fly'
(\"and another string th'' as' asd 'ere\")
labelForStrings: {
`t'is a \"string\"`
}
}
/*asd *****
* 324 @*l;;?\\\\\\
* multiline comment
*** /
*/";
let substitution = "$1$2$3$4";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}