#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=Food:\s)[\s\S]*?(?=Color)"
Local $sString = "Food:" & @CRLF & _
"2000 Apple, Banana," & @CRLF & _
"Chicken " & @CRLF & _
"Color" & @CRLF & _
"1 Blue" & @CRLF & _
"2 Red" & @CRLF & _
"3 Yellow" & @CRLF & _
"4 Green" & @CRLF & _
"5 Purple " & @CRLF & _
"Country"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")