$re = '/(?<=Food:\s)[\s\S]*?(?=Color)/m';
$str = 'Food:
2000 Apple, Banana,
Chicken
Color
1 Blue
2 Red
3 Yellow
4 Green
5 Purple
Country';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);