import Foundation
let pattern = #"(?:(?'Key'[^\n][\w|\s]*)=(?'Value'[^;'"",`\n]+);?)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
AccountEndpoint=https://some-base-name.documents.azure.com:443/;AccountKey=kascuh9823nfsdvxc==;
Endpoint=sb://other-more-different-name.servicebus.windows.net/;SharedAccessKeyName=mysak-name;SharedAccessKey=msd8fs2bsc==;EntityPath=someentitypath;TransportType=Amqp
Data Source=myServerName.whatever.local;Initial Catalog=MyDatabaseName;Persist Security Info=True;User ID=myUserId;Password=MyBadPractice;MultipleActiveResultSets=True;MultiSubnetFailover=True;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)