#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>(?>(\((?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!-'*-\[\]-\x7f]++|\\[\x00-\x7f]|(?-1)))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+\))(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+)++)?+)?+(?>(?>[\w\d!#-'*+\/=?^`{-~-]++|(?>"(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!#-\[\]-\x7f]++|\\[\x00-\x7f]))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+"))(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>(?>(\((?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!-'*-\[\]-\x7f]++|\\[\x00-\x7f]|(?-1)))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+\))(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+)++)?+)?+(?>\.(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>(?>(\((?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!-'*-\[\]-\x7f]++|\\[\x00-\x7f]|(?-1)))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+\))(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+)++)?+)?+(?>[\w\d!#-'*+\/=?^`{-~-]++|(?>"(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!#-\[\]-\x7f]++|\\[\x00-\x7f]))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+"))(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>(?>(\((?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!-'*-\[\]-\x7f]++|\\[\x00-\x7f]|(?-1)))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+\))(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+)++)?+)?+)*+)@(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>(?>(\((?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!-'*-\[\]-\x7f]++|\\[\x00-\x7f]|(?-1)))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+\))(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+)++)?+)?+(?>[\w\d!#-'*+\/=?^`{-~-]++(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>(?>(\((?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!-'*-\[\]-\x7f]++|\\[\x00-\x7f]|(?-1)))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+\))(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+)++)?+)?+(?>\.(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>(?>(\((?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!-'*-\[\]-\x7f]++|\\[\x00-\x7f]|(?-1)))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+\))(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+)++)?+)?+[\w\d!#-'*+\/=?^`{-~-]++(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>(?>(\((?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!-'*-\[\]-\x7f]++|\\[\x00-\x7f]|(?-1)))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+\))(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+)++)?+)?+)*+|\[(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!-Z^-\x7f]++|\\[\x00-\x7f]))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+\](?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>(?>(\((?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!-'*-\[\]-\x7f]++|\\[\x00-\x7f]|(?-1)))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+\))(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+)++)?+)?+)$"
Local $sString = "john.smith@example.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")