const regex = /^(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>(?>(\((?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!-'*-\[\]-\x7f]++|\\[\x00-\x7f]|(?-1)))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+\))(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+)++)?+)?+(?>(?>[\w\d!#-'*+\/=?^`{-~-]++|(?>"(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!#-\[\]-\x7f]++|\\[\x00-\x7f]))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+"))(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>(?>(\((?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!-'*-\[\]-\x7f]++|\\[\x00-\x7f]|(?-1)))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+\))(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+)++)?+)?+(?>\.(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>(?>(\((?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!-'*-\[\]-\x7f]++|\\[\x00-\x7f]|(?-1)))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+\))(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+)++)?+)?+(?>[\w\d!#-'*+\/=?^`{-~-]++|(?>"(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!#-\[\]-\x7f]++|\\[\x00-\x7f]))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+"))(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>(?>(\((?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!-'*-\[\]-\x7f]++|\\[\x00-\x7f]|(?-1)))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+\))(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+)++)?+)?+)*+)@(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>(?>(\((?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!-'*-\[\]-\x7f]++|\\[\x00-\x7f]|(?-1)))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+\))(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+)++)?+)?+(?>[\w\d!#-'*+\/=?^`{-~-]++(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>(?>(\((?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!-'*-\[\]-\x7f]++|\\[\x00-\x7f]|(?-1)))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+\))(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+)++)?+)?+(?>\.(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>(?>(\((?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!-'*-\[\]-\x7f]++|\\[\x00-\x7f]|(?-1)))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+\))(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+)++)?+)?+[\w\d!#-'*+\/=?^`{-~-]++(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>(?>(\((?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!-'*-\[\]-\x7f]++|\\[\x00-\x7f]|(?-1)))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+\))(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+)++)?+)?+)*+|\[(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!-Z^-\x7f]++|\\[\x00-\x7f]))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+\](?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>(?>(\((?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!-'*-\[\]-\x7f]++|\\[\x00-\x7f]|(?-1)))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+\))(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+)++)?+)?+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?>(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+(?>(?>(\\((?>(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+(?>[\\x01-\\x08\\x0b\\x0c\\x0e-\\x1f!-\'*-\\[\\]-\\x7f]++|\\\\[\\x00-\\x7f]|(?-1)))*+(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+\\))(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+)++)?+)?+(?>(?>[\\w\\d!#-\'*+\\\/=?^`{-~-]++|(?>"(?>(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+(?>[\\x01-\\x08\\x0b\\x0c\\x0e-\\x1f!#-\\[\\]-\\x7f]++|\\\\[\\x00-\\x7f]))*+(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+"))(?>(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+(?>(?>(\\((?>(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+(?>[\\x01-\\x08\\x0b\\x0c\\x0e-\\x1f!-\'*-\\[\\]-\\x7f]++|\\\\[\\x00-\\x7f]|(?-1)))*+(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+\\))(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+)++)?+)?+(?>\\.(?>(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+(?>(?>(\\((?>(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+(?>[\\x01-\\x08\\x0b\\x0c\\x0e-\\x1f!-\'*-\\[\\]-\\x7f]++|\\\\[\\x00-\\x7f]|(?-1)))*+(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+\\))(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+)++)?+)?+(?>[\\w\\d!#-\'*+\\\/=?^`{-~-]++|(?>"(?>(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+(?>[\\x01-\\x08\\x0b\\x0c\\x0e-\\x1f!#-\\[\\]-\\x7f]++|\\\\[\\x00-\\x7f]))*+(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+"))(?>(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+(?>(?>(\\((?>(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+(?>[\\x01-\\x08\\x0b\\x0c\\x0e-\\x1f!-\'*-\\[\\]-\\x7f]++|\\\\[\\x00-\\x7f]|(?-1)))*+(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+\\))(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+)++)?+)?+)*+)@(?>(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+(?>(?>(\\((?>(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+(?>[\\x01-\\x08\\x0b\\x0c\\x0e-\\x1f!-\'*-\\[\\]-\\x7f]++|\\\\[\\x00-\\x7f]|(?-1)))*+(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+\\))(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+)++)?+)?+(?>[\\w\\d!#-\'*+\\\/=?^`{-~-]++(?>(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+(?>(?>(\\((?>(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+(?>[\\x01-\\x08\\x0b\\x0c\\x0e-\\x1f!-\'*-\\[\\]-\\x7f]++|\\\\[\\x00-\\x7f]|(?-1)))*+(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+\\))(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+)++)?+)?+(?>\\.(?>(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+(?>(?>(\\((?>(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+(?>[\\x01-\\x08\\x0b\\x0c\\x0e-\\x1f!-\'*-\\[\\]-\\x7f]++|\\\\[\\x00-\\x7f]|(?-1)))*+(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+\\))(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+)++)?+)?+[\\w\\d!#-\'*+\\\/=?^`{-~-]++(?>(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+(?>(?>(\\((?>(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+(?>[\\x01-\\x08\\x0b\\x0c\\x0e-\\x1f!-\'*-\\[\\]-\\x7f]++|\\\\[\\x00-\\x7f]|(?-1)))*+(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+\\))(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+)++)?+)?+)*+|\\[(?>(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+(?>[\\x01-\\x08\\x0b\\x0c\\x0e-\\x1f!-Z^-\\x7f]++|\\\\[\\x00-\\x7f]))*+(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+\\](?>(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+(?>(?>(\\((?>(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+(?>[\\x01-\\x08\\x0b\\x0c\\x0e-\\x1f!-\'*-\\[\\]-\\x7f]++|\\\\[\\x00-\\x7f]|(?-1)))*+(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+\\))(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+)++)?+)?+)$', 'gm')
const str = `john.smith@example.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}