#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b(o(?1)?o)\b"
Local $sString = "o 1" & @CRLF & _
"oo 2" & @CRLF & _
"ooo 3" & @CRLF & _
"oooo 4" & @CRLF & _
"ooooo 5" & @CRLF & _
"oooooo 6 " & @CRLF & _
"ooooooo 7 " & @CRLF & _
"oooooooo 8" & @CRLF & _
"ooooooooo 9" & @CRLF & _
"oooooooooo 10" & @CRLF & _
"ooooooooooo 11" & @CRLF & _
"oooooooooooo 12" & @CRLF & _
"ooooooooooooo 13" & @CRLF & _
"oooooooooooooo 14" & @CRLF & _
"ooooooooooooooo 15" & @CRLF & _
"oooooooooooooooo 16" & @CRLF & _
"ooooooooooooooooo 17" & @CRLF & _
"oooooooooooooooooo 18" & @CRLF & _
"ooooooooooooooooooo 19" & @CRLF & _
"oooooooooooooooooooo 20" & @CRLF & _
"ooooooooooooooooooooo 21" & @CRLF & _
"oooooooooooooooooooooo 22" & @CRLF & _
"ooooooooooooooooooooooo 23" & @CRLF & _
"oooooooooooooooooooooooo 24" & @CRLF & _
"ooooooooooooooooooooooooo 25" & @CRLF & _
"oooooooooooooooooooooooooo 26" & @CRLF & _
"ooooooooooooooooooooooooooo 27" & @CRLF & _
"oooooooooooooooooooooooooooo 28" & @CRLF & _
"ooooooooooooooooooooooooooooo 29" & @CRLF & _
"oooooooooooooooooooooooooooooo 30" & @CRLF & _
"ooooooooooooooooooooooooooooooo 31" & @CRLF & _
"oooooooooooooooooooooooooooooooo 32" & @CRLF & _
"ooooooooooooooooooooooooooooooooo 33" & @CRLF & _
"oooooooooooooooooooooooooooooooooo 34" & @CRLF & _
"ooooooooooooooooooooooooooooooooooo 35" & @CRLF & _
"oooooooooooooooooooooooooooooooooooo 36 " & @CRLF & _
"ooooooooooooooooooooooooooooooooooooo 37 " & @CRLF & _
"oooooooooooooooooooooooooooooooooooooo 38" & @CRLF & _
"ooooooooooooooooooooooooooooooooooooooo 39" & @CRLF & _
"oooooooooooooooooooooooooooooooooooooooo 40" & @CRLF & _
"ooooooooooooooooooooooooooooooooooooooooo 41" & @CRLF & _
"oooooooooooooooooooooooooooooooooooooooooo 42" & @CRLF & _
"ooooooooooooooooooooooooooooooooooooooooooo 43" & @CRLF & _
"oooooooooooooooooooooooooooooooooooooooooooo 44" & @CRLF & _
"ooooooooooooooooooooooooooooooooooooooooooooo 45" & @CRLF & _
"oooooooooooooooooooooooooooooooooooooooooooooo 46" & @CRLF & _
"ooooooooooooooooooooooooooooooooooooooooooooooo 47" & @CRLF & _
"oooooooooooooooooooooooooooooooooooooooooooooooo 48" & @CRLF & _
"ooooooooooooooooooooooooooooooooooooooooooooooooo 49" & @CRLF & _
"oooooooooooooooooooooooooooooooooooooooooooooooooo 50" & @CRLF & _
"ooooooooooooooooooooooooooooooooooooooooooooooooooo 51" & @CRLF & _
"oooooooooooooooooooooooooooooooooooooooooooooooooooo 52" & @CRLF & _
"ooooooooooooooooooooooooooooooooooooooooooooooooooooo 53" & @CRLF & _
"oooooooooooooooooooooooooooooooooooooooooooooooooooooo 54" & @CRLF & _
"ooooooooooooooooooooooooooooooooooooooooooooooooooooooo 55" & @CRLF & _
"oooooooooooooooooooooooooooooooooooooooooooooooooooooooo 56" & @CRLF & _
"ooooooooooooooooooooooooooooooooooooooooooooooooooooooooo 57" & @CRLF & _
"oooooooooooooooooooooooooooooooooooooooooooooooooooooooooo 58" & @CRLF & _
"ooooooooooooooooooooooooooooooooooooooooooooooooooooooooooo 59" & @CRLF & _
"oooooooooooooooooooooooooooooooooooooooooooooooooooooooooooo 60" & @CRLF & _
"ooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooo 61" & @CRLF & _
"oooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooo 62" & @CRLF & _
"ooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooo 63" & @CRLF & _
"oooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooo 64" & @CRLF & _
"ooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooo 65"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")