re = /^((\+|00)?968)?[279]\d{7}$/m
str = '22345678
72345678
92345678
+96822345678
0096822345678
96822345678
+96872345678
0096872345678
96827345678
+96829345678
0096892345678
96892345678
12345678
+96812345678
0096812345678
96812345678'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end