package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:[0-9A-Za-z][0-9A-Za-z-]{0,62})(?:\.(?:[0-9A-Za-z][0-9A-Za-z-]{0,62}))*(\.?|\b)`)
var str = `ip_block-hgTest.Dev1test-2021-03-10_09_10.log`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}