re = /\b(?:[0-9A-Za-z][0-9A-Za-z-]{0,62})(?:\.(?:[0-9A-Za-z][0-9A-Za-z-]{0,62}))*(\.?|\b)/m
str = 'ip_block-hgTest.Dev1test-2021-03-10_09_10.log'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end