#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(.*?)(-SNAPSHOT)?$"
Local $sString = "1.0.0" & @CRLF & _
"1.0.0-SNAPSHOT"
Local $sSubst = "\1-SNAPSHOT"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)