$re = '/^(.*?)(-SNAPSHOT)?$/m';
$str = '1.0.0
1.0.0-SNAPSHOT';
$subst = "\1-SNAPSHOT";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;