package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([A-Z]{3,7})((\s[A-Z]{0,3})?(\s[A-Z]{4,}))?$`)
var str = `LOL`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}