$re = '/^([A-Z]{3,7})((\s[A-Z]{0,3})?(\s[A-Z]{4,}))?$/m';
$str = 'LOL';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);