$re = '/^Z(?:I[^U]|[^I]).*$/m';
$str = 'ZISADR
ZIUSADR
ZDDDDR
ZISADR
ZAUSDR
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);