#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([A-Z]{3})(?:.*?)([A-Z]{3})(?:.*?)((\d{1,2}\/\d{1,2}\/\d{4})|(\d{1,2}(?:.*?)(January|February|March|April|May|June|July|August|September|October|December)( (\d{4}))?)|(\d{1,2}(?:.*?)(Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec)( (\d{4}))?))"
Local $sString = "TRZ dupa dupa dupa siurak KFR GTB GTT TGH 5 10 15 20:30 5/12/2587 " & @CRLF & _
"dupa KGB TRZ dupa siurak KFR GTB 5 Jan ssdsdsdsd" & @CRLF & _
"dupa KGB TRZ dupa siurak KFR GTB 5 Jan 1235" & @CRLF & _
"" & @CRLF & _
"dupa KGB TRZ dupa siurak KFR GTB 5 January sdsdsdsd" & @CRLF & _
"dupa KGB TRZ dupa siurak KFR GTB 5 January 2315"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)