import re
regex = re.compile(r"([A-Z]{3})(?:.*?)([A-Z]{3})(?:.*?)((\d{1,2}\/\d{1,2}\/\d{4})|(\d{1,2}(?:.*?)(January|February|March|April|May|June|July|August|September|October|December)( (\d{4}))?)|(\d{1,2}(?:.*?)(Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec)( (\d{4}))?))")
test_str = ("TRZ dupa dupa dupa siurak KFR GTB GTT TGH 5 10 15 20:30 5/12/2587 \n"
"dupa KGB TRZ dupa siurak KFR GTB 5 Jan ssdsdsdsd\n"
"dupa KGB TRZ dupa siurak KFR GTB 5 Jan 1235\n\n"
"dupa KGB TRZ dupa siurak KFR GTB 5 January sdsdsdsd\n"
"dupa KGB TRZ dupa siurak KFR GTB 5 January 2315")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)