# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<img\b.*?\bsrc=['\"](?!https?:\/\/img\.[a-z0-9]*\.test\/)([^'\"]*)"
test_str = ("<img alt='' src='http://img.dev.teeeest/images/UID' />\n"
"<img alt='' src='https://img.deaaav.test.com/images/UID/' />\n"
"<img alt='' src='http://api.com/images/UID' />\n"
"<img alt='' src='http://img.deaSassav.test/images/UID' />\n"
"<img alt='' src='https://img.dev.test/images/UID' />")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.