const regex = new RegExp('(?:/pattern,|(?!^)\\G)[^\\n/-]*\\K-', 'gm')
const str = `/some-folders/../pattern,replacement-area
/some-folders/../pattern,also-replacement-area/parameter-one
`;
const subst = `~`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);