$re = '~(?:/pattern,|(?!^)\G)[^\n/-]*\K-~m';
$str = '/some-folders/../pattern,replacement-area
/some-folders/../pattern,also-replacement-area/parameter-one
';
$subst = "~";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;