using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:youtube(?:-nocookie)?\.com/(?:[^/]+/.+/|(?:v|e(?:mbed)?)/|.*[?&]v=)|youtu\.be/)\K[^""&?/ ]{11}|vimeo\.com/(?:[a-z]+/)*\K[0-9]{6,11}";
string input = @"https://vimeo.com/341989332 or https://www.youtube.com/watch?v=eUMbH6X_Adc";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}