re = /(?:youtube(?:-nocookie)?\.com\/(?:[^\/]+\/.+\/|(?:v|e(?:mbed)?)\/|.*[?&]v=)|youtu\.be\/)\K[^"&?\/ ]{11}|vimeo\.com\/(?:[a-z]+\/)*\K[0-9]{6,11}/m
str = 'https://vimeo.com/341989332 or https://www.youtube.com/watch?v=eUMbH6X_Adc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end