package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{3}(\s*|-)\d{2}(\s*|-)\d{4}$`)
var str = `555-50-1234
555501234
555 50 1234 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}