$re = '/^\d{3}(\s*|-)\d{2}(\s*|-)\d{4}$/m';
$str = '555-50-1234
555501234
555 50 1234 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);