package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<url>(https|http):\/\/\w+\/\w+\/)`)
var str = `https://xxxx/yyyy/test`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}