using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^F\d+";
string input = @"F1-UPPERFRAME EXCL RS
F02 ZB QUARTRAE";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}