$re = '/^F\d+/m';
$str = 'F1-UPPERFRAME EXCL RS
F02 ZB QUARTRAE';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);