using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"aze.(\S+)*";
string input = @"string1 aze string2 eza string3 aze string4 eza string5";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}