$re = '/aze.(\S+)*/';
$str = 'string1 aze string2 eza string3 aze string4 eza string5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);