$re = '/data\-event\-title\=\"(.+?)\"[^\0]*class\=\"odds\".*\>(.+?)\</';
$str = 'data-event-title="Yuichi Sugita* vs Adrian Mannarino">
<span class="odds-container">
<b class="odds">1/12</b>
</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);