// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"data\-event\-title\=\"(.+?)\"[^\0]*class\=\"odds\".*\>(.+?)\<"#).unwrap();
let string = "data-event-title=\"Yuichi Sugita* vs Adrian Mannarino\">
<span class=\"odds-container\">
<b class=\"odds\">1/12</b>
</a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}