package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Phone=(.*)|`)
var str = `Name=Joe|LastName=Doe|City=NY|Country=US|Currency=$|Phone=0123456789|Adress=null`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}