re = /Phone=(.*)|/m
str = 'Name=Joe|LastName=Doe|City=NY|Country=US|Currency=$|Phone=0123456789|Adress=null'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end