package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[sS][pP][rR][iI][nN][gG]|[fF][aA][lL][lL]|[sS][uU][mM][mM][eE][rR]|[wW][iI][nN][tT][eE][rR])20[2-9][0-9]$`)
var str = `spring2021
SPriNg2023
Fall2099`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}