const regex = new RegExp('^(?:[sS][pP][rR][iI][nN][gG]|[fF][aA][lL][lL]|[sS][uU][mM][mM][eE][rR]|[wW][iI][nN][tT][eE][rR])20[2-9][0-9]$', 'gm')
const str = `spring2021
SPriNg2023
Fall2099`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}