using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img(?=\s)(?=(?:[^>""']|""[^""]*""|'[^']*')*?\ssrc\s*=\s*(?:(['""])(?:(?!\1)[\S\s])*?\/storage\/(\d+)\/articles\/pictures\/((?:(?!\1)[\S\s])*)\1))\s+(?:""[\S\s]*?""|'[\S\s]*?'|[^>]*?)+>";
string input = @"
$body = ""... Cras ut tristique est. Etiam porttitor elit velit, vitae consequat eros interdum ac. Nam in blandit ante.</p><p> </p><figure class=""image""><img src=""/storage/5/articles/pictures/1560534410321_a363bc0d804aec432567128ed10416ee.jpeg""></figure><p>Integer sed justo accumsan, consequat nulla at, tincidunt massa. Integer orna Etiam porttitor elit velit, vitae consequat eros interdum ac. Nam in blandit ante.</p><p> </p><figure class=""image""><img src=""/storage/5/articles/pictures/23456410321_a33456t604aec432567128ed10416ee.jpeg""></figure> j hgfjhf jfhfj hgf jh786 876 8 76fgj tfyt u ufgi uyu y gi iy gygg ..."";
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}