import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img(?=\\s)(?=(?:[^>\"']|\"[^\"]*\"|'[^']*')*?\\ssrc\\s*=\\s*(?:(['\"])(?:(?!\\1)[\\S\\s])*?\\/storage\\/(\\d+)\\/articles\\/pictures\\/((?:(?!\\1)[\\S\\s])*)\\1))\\s+(?:\"[\\S\\s]*?\"|'[\\S\\s]*?'|[^>]*?)+>";
final String string = "\n\n"
+ "$body = \"... Cras ut tristique est. Etiam porttitor elit velit, vitae consequat eros interdum ac. Nam in blandit ante.</p><p> </p><figure class=\"image\"><img src=\"/storage/5/articles/pictures/1560534410321_a363bc0d804aec432567128ed10416ee.jpeg\"></figure><p>Integer sed justo accumsan, consequat nulla at, tincidunt massa. Integer orna Etiam porttitor elit velit, vitae consequat eros interdum ac. Nam in blandit ante.</p><p> </p><figure class=\"image\"><img src=\"/storage/5/articles/pictures/23456410321_a33456t604aec432567128ed10416ee.jpeg\"></figure> j hgfjhf jfhfj hgf jh786 876 8 76fgj tfyt u ufgi uyu y gi iy gygg ...\";\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}