$re = '/-(?=[^\']*\'(?:(?:[^\']*\'){2})*[^\']*$)/m';
$str = '( NOT TABLE-FIELD BETWEEN \'XX-XX\' AND \'XX-XX\' ) AND ( TABLE-FIELD = \'XXX-XXX-XXX\' )';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);