re = /-(?=[^']*'(?:(?:[^']*'){2})*[^']*$)/m
str = '( NOT TABLE-FIELD BETWEEN \'XX-XX\' AND \'XX-XX\' ) AND ( TABLE-FIELD = \'XXX-XXX-XXX\' )'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end